ZW3D Dongle codes for 2012 not ready

I think this is like viewing a slow motion  train wreck where I sit  in the passenger coach and watch as we creep towards disaster.

So I request my dongle code for 2012 and the reply is that the codes are not ready but they should be within two weeks. Does anyone check anything out there before release?

I go to the forums and I know that the forum is not a part of the software I use but it is an important part of the public face of the company.  I would think they would understand that this should work right as it is one of the first places many prospective customers will go to form an opinion. So you go there  and it is total chaos. No categories, no evident order to posts and the sort by’s at the top don’t  sort. http://www.zwsoft.com/en/forum/forumdisplay.php?fid=3

They have also taken to removing critical posts that complain about these things and I guess if the ostrich can’t see it when it’s head is in the ground the problem has gone away.

Rumor has it that now that they have released 2012 with lathe that no one can use they are in negotiations with a third-party post company.  My question is how did it get so far without this question being answered? ZW3D has known all along they had no way for you to communicate with your lathe but it was not important to them to resolve this before you plunked your cash down.

I don’t intend to talk long about this stuff today but I will say that first and foremost I am a user of cad and cam. I think that if someone told me that a particular software program was good and convinced me to buy it, then it should be good. Lets face it, the only reason we users have this stuff for is to make a living and anything that gets in the way of that is counter productive.

I go over the fanboy top sometimes in other peoples eyes when I talk about Solid Edge. It may sound corny but I am very happy to be there and I am as happy and enthusiastic about SE as I can be. It has made my cad life that much easier and I tell you so.

On the other hand we have ZW3D. I am going to tell you that my experience here has quickly gone downhill since VX was bought out and I can’t think of anything that would convince me to tell you to buy it. My only reason for hanging on was the promise of lathe being added to cam and I was being a tightwad and hoping to save some money.  Just remember please that when I talk about the programs I use it was my own money I have spent. ZW3D is such a lousy MCAD program that I have never used it for cad since Solid Edge so capably replaced it three plus years ago.   Now I am faced with no lathe and all I can say about ZW3D is if you go there, beware.

The train it appears is heading down Cajon Pass with no dynamic brakes working and do you really want to be there as a participant?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s